Использование Composer с OpenServer на Windows

👁 95 просмотров

Composer — это инструмент управления зависимостями в PHP. Он позволяет вам декларировать библиотеки, от которых зависит ваш проект, и он будет управлять (устанавливать / обновлять) их для вас.

Composer не является менеджером пакетов в том же смысле, что и Yum или Apt. Да, он имеет дело с «пакетами» или библиотеками, но управляет ими на основе каждого проекта, устанавливая их в каталоге (например, vendor) внутри вашего проекта. По умолчанию он не устанавливает ничего глобально. Таким образом, это менеджер зависимостей. Тем не менее, он поддерживает глобальный проект для удобства с помощью глобальной команды. Эта идея не нова, и композитор сильно вдохновлен npm в Node.js и менеджером пакетов в ruby.

Предположим:

  1. У вас есть проект, который зависит от ряда библиотек.
  2. Некоторые из этих библиотек зависят от других библиотек.

Что делает Composer:

  1. Позволяет объявлять библиотеки, на которых вы зависите.
  2. Определяет, какие версии пакетов могут и должны быть установлены, и устанавливает их (что означает, что они загружаются их в ваш проект).

Для запуска Composer требуется PHP 5.3.2+. Также требуются несколько чувствительных настроек php и флагов компиляции, но при использовании установщика вы будете предупреждены о любых несовместимостях.

Для установки пакетов из источников вместо простых zip-архивов вам понадобятся git, svn, fossil или hg в зависимости от того, как пакет управляется версией.

Composer является многоплатформенным, и разработчики стремятся сделать его одинаково хорошо работающим в Windows, Linux и OSX.

Настройка OpeServer

Для начала необходимо выбрать один из версий модулей PHP 5.3.2+, с которым устанвалвиваемый Composer будет работать. Делается это в настройках

Установка при помощи инсталятора Windows

Установщик загрузит композитор для вас и настроит переменную среды PATH, чтобы вы могли просто вызвать композитор из любого каталога.

Загрузите и запустите Composer-Setup.exe — он будет устанавливать последнюю версию композитора всякий раз, когда он выполняется. В процессе установки установщик запросит место установки и путь к PHP, который нужно указать тот, который мы выбрали в настройках Open Server. Версии модулей PHP у Open Server находятся по пути Open Server\modules\php\[PHP-5.6-x64].

Далее проверяем версию, чтобы убедится на то, что Composer удачно установился командой

php composer.phar -V

Чтобы выполнять команды Composer по команде composer добавляем путь в PATH

echo @php "%~dp0composer.phar" %*>composer.bat

Она создаст .bat файл и в дальнейшем можно будет работать без указания php composer.phar, просто указывая composer Т.е. команда проверки версии (которая была выше) будет выглядеть так:

composer -V

Установка при помощи CMD Windows

Чтобы быстро установить Composer в текущем каталоге, запустите в своем терминале следующий сценарий

php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
php -r "if (hash_file('SHA384', 'composer-setup.php') === '544e09ee996cdf60ece3804abc52599c22b1f40f4323403c44d44fdfdd586475ca9813a858088ffbc1f233e9b180f061') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
php composer-setup.php
php -r "unlink('composer-setup.php');"

Этот скрипт установщика будет просто проверять некоторые настройки php.ini, предупреждать вас, если они установлены неправильно, а затем загрузить последнюю версию composer.phar в текущем каталоге. 4 строчки выше, делают следующие действия:

  • Загружает установщик в текущий каталог
  • Проверяет установщик на SHA-384, который вы также можете перекрестно проверить здесь.
  • Запускает установщик
  • Удаляет установщик

Далее проверяем версию, чтобы убедится на то, что Composer удачно установился командой

php composer.phar -V

Чтобы выполнять команды Composer по команде composer добавляем путь в PATH

echo @php "%~dp0composer.phar" %*>composer.bat

Она создаст .bat файл и в дальнейшем можно будет работать без указания php composer.phar, просто указывая composer Т.е. команда проверки версии (которая была выше) будет выглядеть так:

composer -V